読者です 読者をやめる 読者になる 読者になる

tak0kadaの何でもノート

発声練習、生存確認用。

医学関連は 医学ノート

devtools, roxygen2, testthatのインストール

Rのパッケージング関連でAdvanced Rを読んだが、install.package("devtools")してもパッケージが入らない。

 警告メッセージ: 
1: In install.packages("devtools") :
   パッケージ ‘RCurl’ のインストールは、ゼロでない終了値をもちました 
2: In install.packages("devtools") :
   パッケージ ‘httr’ のインストールは、ゼロでない終了値をもちました 
3: In install.packages("devtools") :
   パッケージ ‘devtools’ のインストールは、ゼロでない終了値をもちました 

stackoverflowに記事があったのでそれに従う。 Qiita: Install R3.0.1 on Ubuntu 12.04LTSにも同様の内容がある。

sudo apt-get install libcurl4-gnutls-dev

ここから後は

install.packages(c("devtools", "roxygen2", "testthat"))

で完了。